or Connect
Styleforum › Forums › Men's Style › Classic Menswear › Computer problem
New Posts  All Forums:Forum Nav:

Computer problem

post #1 of 16
Thread Starter 
Accidentally (obviously) when I right-clicked a shortcut under the recently-viewed documents menu under the start button I selected "open with Staroffice 6.0" when prompted, and "Always use this program" was checked. So my problem now is that even my desktop (.lnk) shortcuts don't work when double-clicked. Staroffice doesn't know how to handle .lnk shortcut files. Ideas on how to rectify this problem? I need Windows to handle .lnk shortcuts like it used to. Now every time I want to open a program, with the exception of IE, I've got to go to WIndows Explorer and double-click on the executable file itself, which is getting annoying. Many thanks in advance.
post #2 of 16
Send a PM to NickM, he might be able to help.
post #3 of 16
Thread Starter 
Thanks - will do.
post #4 of 16
Unless there is a quicker way to UNDO this, Click on your windows explorer (windows key together with E), On the menu above there is a tools option> Folder Options>File Types Tab and then click on each non functioning file and specify which file to open with.(on the bottom of the pop up) Also you may want to try Uninstalling Staroffice and then they all may revert to a default. What is Star office? Good luck. JJF
post #5 of 16
Thread Starter 
JJF, thanks. I will look into trying what you have described. Staroffice is the Sun Microsystems equivalent of Microsoft Office. I bought it a couple of years ago because it also works with Linux. Now there is an opensource free version called Openoffice.
post #6 of 16
What JJF said will work , but here's what I generally do: Right click on a file with .lnk filetype, and choose "Open With"->"Choose Program...". You should get a window with all the programs currently installed - choose the right one from these, and click the checkbox for "Always use this program." Should work - I've moved between different applications opening the same file type using this.
post #7 of 16
Thread Starter 
Aarghh, that trick normally works for me, but in this instance I am unable to find something which would handle shortcuts (.lnk files). Handling of shortcuts is by default embedded in the Windows interface. ??
post #8 of 16
Quote:
Aarghh, that trick normally works for me, but in this instance I am unable to find something which would handle shortcuts (.lnk files).  Handling of shortcuts is by default embedded in the Windows interface.  ??
Banks: Shortcuts arent their own programs. They just point to an executable file, so essentially whats happening is when you double click on a file it points to the executable program oor a file that normally opens ith another executable and THAT opens with Staroffice. Try doing what I told you and then on the type of file you are working with to open with its respective program. Gluck (and good night. 1 AM here and I leave for Bari in the AM.) JJF
post #9 of 16
Thread Starter 
JJF, therein lies the problem. The question is, must I use RegEdit and manually make changes to restore the way in which .lnk files were handled before? If so, how? It's been a couple years since I last used RegEdit.
post #10 of 16
Quote:
JJF, therein lies the problem.  The question is, must I use RegEdit and manually make changes to restore the way in which .lnk files were handled before?  If so, how?  It's been a couple years since I last used RegEdit.
I cannot believe that a command that was initiated in windows can only be undone with Dos commands. in the words of Royal Tennenbaum. hey, thats just one man's view" Gnight. JJF Personally I vote for a windows reinstal...
post #11 of 16
If you're running XP - just use the restore capability built into the OS. Choose a point in time before (as close as possible to the actual time you made the change) and all will be returned to normal. You may have to re-install any software added to your machine since the change.
post #12 of 16
Thread Starter 
If this is of any importance in fixing the problem, I'm using Windows 2000 on this computer.
post #13 of 16
This assumes you have some experience with editing the registry, but try this link: http://www.experts-exchange.com/Operati....37.html The question is for w95 but the answer toward the bottom by "JD" is for NT etc. (Use the NT solution.)
post #14 of 16
Quote:
JJF, therein lies the problem. The question is, must I use RegEdit and manually make changes to restore the way in which .lnk files were handled before? If so, how? It's been a couple years since I last used RegEdit.
Sorry - I should have realized about .lnk. Regedit seems to be the way to go - type regedit in the Programs->Run box, and it should be under HKEY_CLASSES_ROOT - there seem to be several sub-keys in my computer, but here is what I have: ShellEx and ShellNew - with some numbers under Shellex, and two values under ShellNew - one with no value set, and the other "command" with the value rundll32.exe. Hope that helps Edit: Just saw j's post - that's exactly what you need to do.
post #15 of 16
Hi, This article explains exactly what you have to do: http://www.jsiinc.com/subh/tip3500/rh3540.htm You might also be able to use the assoc command to change the .lnk file association but I don't have immediate access to windows 2000 to see if that'll work or not.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Classic Menswear
Styleforum › Forums › Men's Style › Classic Menswear › Computer problem